scrub-obsolete Package - ocamlgraph

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/ocamlgraph scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index ac508f0..5e3c8d1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ ocamlgraph (1.8.8-2) UNRELEASED; urgency=low
   * debian/copyright: use spaces rather than tabs to start continuation lines.
   * Bump debhelper from deprecated 7 to 10.
   * Make "Files: *" paragraph the first in the copyright file.
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on dh-ocaml, debhelper,
+      docbook-xml.
 
  -- Debian Janitor <janitor@jelmer.uk>  Mon, 20 Jul 2020 03:05:29 -0000
 
diff --git a/debian/control b/debian/control
index e0fc93a..8def116 100644
--- a/debian/control
+++ b/debian/control
@@ -5,11 +5,11 @@ Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
 Uploaders: Mehdi Dogguy <mehdi@debian.org>
 Build-Depends:
  cdbs,
- dh-ocaml (>= 0.9),
- debhelper (>= 10~),
+ dh-ocaml,
+ debhelper,
  ocaml-nox (>= 3.11.1),
  ocaml-findlib (>> 1.2.4-2),
- docbook-xml (>= 4.4),
+ docbook-xml,
  docbook-xsl,
  libxml2-utils,
  xsltproc,

Run locally

Try this locally (using the lintian-brush package):

debcheckout ocamlgraph
cd ocamlgraph
deb-scrub-obsolete

More details

Full run details