scrub-obsolete Package - plexus-archiver

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/plexus-archiver scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 23489b3..a17fdc7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+plexus-archiver (3.6.0-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on libcommons-compress-java.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 14 Nov 2020 21:22:36 -0000
+
 plexus-archiver (3.6.0-2) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index d88c85f..836df06 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends:
  debhelper (>= 11~),
  default-jdk,
  junit4,
- libcommons-compress-java (>= 1.9),
+ libcommons-compress-java,
  libplexus-component-metadata-java,
  libplexus-container-default1.5-java,
  libplexus-io-java (>= 3.0),

Run locally

Try this locally (using the lintian-brush package):

debcheckout plexus-archiver
cd plexus-archiver
deb-scrub-obsolete

More details

Full run details