scrub-obsolete Package - qca2

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/qca2 scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index c16cf17..8805565 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+qca2 (2.3.1-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, pkg-kde-tools.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 11 Nov 2020 17:53:38 -0000
+
 qca2 (2.3.1-1) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index 6198fc3..e363fdd 100644
--- a/debian/control
+++ b/debian/control
@@ -5,12 +5,12 @@ Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Felix Geyer <fgeyer@debian.org>,
            Maximiliano Curia <maxy@debian.org>,
 Build-Depends: ca-certificates,
-               cmake (>= 3.4~),
+               cmake,
                debhelper-compat (= 12),
                libsasl2-dev,
                libssl-dev (>= 1.1.1~),
                pkg-config,
-               pkg-kde-tools (>= 0.15.16),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.6.0~),
 Build-Depends-Indep: doxygen,
                      graphviz,

Run locally

Try this locally (using the lintian-brush package):

debcheckout qca2
cd qca2
deb-scrub-obsolete

More details

Full run details