scrub-obsolete Package - r-cran-plumber

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/r-cran-plumber scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 41dc256..75a50f1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+r-cran-plumber (1.0.0-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on r-cran-r6, r-cran-stringi,
+      r-cran-jsonlite.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 23 Nov 2020 02:13:57 -0000
+
 r-cran-plumber (1.0.0-1) unstable; urgency=medium
 
   * New upstream version
diff --git a/debian/control b/debian/control
index 4ca928f..b146698 100644
--- a/debian/control
+++ b/debian/control
@@ -7,9 +7,9 @@ Priority: optional
 Build-Depends: debhelper-compat (= 13),
                dh-r,
                r-base-dev,
-               r-cran-r6 (>= 2.0.0),
-               r-cran-stringi (>= 0.3.0),
-               r-cran-jsonlite (>= 0.9.16),
+               r-cran-r6,
+               r-cran-stringi,
+               r-cran-jsonlite,
                r-cran-webutils (>= 1.1),
                r-cran-httpuv (>= 1.5.0),
                r-cran-crayon,

Run locally

Try this locally (using the lintian-brush package):

debcheckout r-cran-plumber
cd r-cran-plumber
deb-scrub-obsolete

More details

Full run details