scrub-obsolete Package - ruby-celluloid-extras

Ready changes

Merge these changes:

Diff

diff --git a/debian/changelog b/debian/changelog
index 6eba739..d8c66ae 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,11 @@ ruby-celluloid-extras (0.20.5-2) UNRELEASED; urgency=medium
   * Set debhelper-compat version in Build-Depends.
   * Update Vcs-* headers from URL redirect.
   * Use canonical URL in Vcs-Git.
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on ruby-rspec-logsplit,
+      ruby-timers.
+    + ruby-celluloid-extras: Drop versioned constraint on ruby-rspec-logsplit,
+      ruby-timers in Depends.
 
  -- Utkarsh Gupta <guptautkarsh2102@gmail.com>  Tue, 13 Aug 2019 03:42:47 +0530
 
diff --git a/debian/control b/debian/control
index 458f811..0307480 100644
--- a/debian/control
+++ b/debian/control
@@ -8,8 +8,8 @@ Build-Depends: bundler,
                gem2deb,
                ruby-dotenv,
                ruby-nenv,
-               ruby-rspec-logsplit (>= 0.1.2),
-               ruby-timers (>= 4.1.1)
+               ruby-rspec-logsplit,
+               ruby-timers
 Standards-Version: 3.9.7
 Vcs-Git: https://salsa.debian.org/ruby-team/ruby-celluloid-extras.git
 Vcs-Browser: https://salsa.debian.org/ruby-team/ruby-celluloid-extras
@@ -23,8 +23,8 @@ Depends: bundler,
          ruby | ruby-interpreter,
          ruby-dotenv,
          ruby-nenv,
-         ruby-rspec-logsplit (>= 0.1.2),
-         ruby-timers (>= 4.1.1),
+         ruby-rspec-logsplit,
+         ruby-timers,
          ${misc:Depends},
          ${shlibs:Depends}
 Breaks: ruby-celluloid (<< 0.17~)

Run locally

Try this locally (using the lintian-brush package):

debcheckout ruby-celluloid-extras
cd ruby-celluloid-extras
deb-scrub-obsolete

More details

Full run details