scrub-obsolete Package - ruby-faker

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/ruby-faker scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index a64192c..6b2e4bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ ruby-faker (1.9.1-3) UNRELEASED; urgency=medium
   * Set debhelper-compat version in Build-Depends.
   * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
     Repository-Browse.
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on ruby-i18n.
+    + ruby-faker: Drop versioned constraint on ruby-i18n in Depends.
 
  -- Debian Janitor <janitor@jelmer.uk>  Sat, 11 Apr 2020 11:31:52 +0000
 
diff --git a/debian/control b/debian/control
index 4e2a925..133cb58 100644
--- a/debian/control
+++ b/debian/control
@@ -6,10 +6,10 @@ Uploaders: Balasankar C <balasankarc@autistici.org>
 Build-Depends: debhelper-compat (= 12),
                gem2deb,
                rake,
-               ruby-i18n (>= 0.7),
+               ruby-i18n,
                ruby-timecop,
                ruby-saml,
-               ruby-simplecov,
+               ruby-simplecov
 Standards-Version: 4.5.0
 Vcs-Git: https://salsa.debian.org/ruby-team/ruby-faker.git
 Vcs-Browser: https://salsa.debian.org/ruby-team/ruby-faker
@@ -21,7 +21,7 @@ Rules-Requires-Root: no
 Package: ruby-faker
 Architecture: all
 XB-Ruby-Versions: ${ruby:Versions}
-Depends: ruby-i18n (>= 0.7),
+Depends: ruby-i18n,
          ${misc:Depends},
          ${shlibs:Depends}
 Description: easily generate fake data

Run locally

Try this locally (using the lintian-brush package):

debcheckout ruby-faker
cd ruby-faker
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details