scrub-obsolete Package - ruby-fog-rackspace

Ready changes

Merge these changes:

Diff

diff --git a/debian/changelog b/debian/changelog
index 65ff388..9858bb0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,13 @@ ruby-fog-rackspace (0.1.6-3) UNRELEASED; urgency=medium
   * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
     Repository-Browse.
   * Update standards version to 4.4.1, no changes needed.
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on rake, ruby-fog-core,
+      ruby-fog-json, ruby-fog-xml and ruby-ipaddress.
+    + ruby-fog-rackspace: Drop versioned constraint on ruby-fog-core,
+      ruby-fog-json, ruby-fog-xml and ruby-ipaddress in Depends.
+    + ruby-fog-rackspace: Drop versioned constraint on ruby-fog in Replaces.
+    + ruby-fog-rackspace: Drop versioned constraint on ruby-fog in Breaks.
 
  -- Utkarsh Gupta <guptautkarsh2102@gmail.com>  Tue, 13 Aug 2019 04:59:43 +0530
 
diff --git a/debian/control b/debian/control
index 2f45c12..8f16246 100644
--- a/debian/control
+++ b/debian/control
@@ -6,11 +6,11 @@ Uploaders: Sagar Ippalpalli <i.vikram15@gmail.com>,
                  Pirate Praveen <praveen@debian.org>
 Build-Depends: debhelper-compat (= 12),
                gem2deb,
-               rake (>= 10.0),
-               ruby-fog-core (>= 1.35),
-               ruby-fog-json (>= 1.0),
-               ruby-fog-xml (>= 0.1),
-               ruby-ipaddress (>= 0.8),
+               rake,
+               ruby-fog-core,
+               ruby-fog-json,
+               ruby-fog-xml,
+               ruby-ipaddress,
                ruby-shindo
 Standards-Version: 4.4.1
 Vcs-Git: https://salsa.debian.org/ruby-team/ruby-fog-rackspace.git
@@ -21,13 +21,11 @@ XS-Ruby-Versions: all
 Package: ruby-fog-rackspace
 Architecture: all
 XB-Ruby-Versions: ${ruby:Versions}
-Breaks: ruby-fog (<< 1.38~)
-Replaces: ruby-fog (<< 1.38~)
 Depends: ruby | ruby-interpreter,
-         ruby-fog-core (>= 1.35),
-         ruby-fog-json (>= 1.0),
-         ruby-fog-xml (>= 0.1),
-         ruby-ipaddress (>= 0.8),
+         ruby-fog-core,
+         ruby-fog-json,
+         ruby-fog-xml,
+         ruby-ipaddress,
          ${misc:Depends}
 Description: Rackspace support for Fog
  This project provides a Ruby package of Rackspace

Run locally

Try this locally (using the lintian-brush package):

debcheckout ruby-fog-rackspace
cd ruby-fog-rackspace
deb-scrub-obsolete

More details

Full run details