scrub-obsolete Package - ruby-omniauth-oauth2

Ready changes

Merge these changes:

Diff

diff --git a/debian/changelog b/debian/changelog
index 1305895..412ae6f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+ruby-omniauth-oauth2 (1.7.1-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on ruby-faraday, ruby-multi-json
+      and ruby-oauth2.
+    + ruby-omniauth-oauth2: Drop versioned constraint on ruby-faraday,
+      ruby-multi-json and ruby-oauth2 in Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 10 Apr 2021 10:25:39 -0000
+
 ruby-omniauth-oauth2 (1.7.1-1) experimental; urgency=medium
 
   [ Debian Janitor ]
diff --git a/debian/control b/debian/control
index fea322d..350cf6f 100644
--- a/debian/control
+++ b/debian/control
@@ -5,9 +5,9 @@ Maintainer: Debian Ruby Team <pkg-ruby-extras-maintainers@lists.alioth.debian.or
 Uploaders: Pirate Praveen <praveen@debian.org>
 Build-Depends: debhelper-compat (= 13),
                gem2deb,
-               ruby-faraday (>= 0.8),
-               ruby-multi-json (>= 1.3),
-               ruby-oauth2 (>= 1.1~),
+               ruby-faraday,
+               ruby-multi-json,
+               ruby-oauth2,
                ruby-omniauth (>= 1.9~),
                ruby-rack-test,
                ruby-rspec,
@@ -23,9 +23,9 @@ Package: ruby-omniauth-oauth2
 Architecture: all
 XB-Ruby-Versions: ${ruby:Versions}
 Depends: ruby | ruby-interpreter,
-         ruby-faraday (>= 0.8),
-         ruby-multi-json (>= 1.3),
-         ruby-oauth2 (>= 1.1~),
+         ruby-faraday,
+         ruby-multi-json,
+         ruby-oauth2,
          ruby-omniauth (>= 1.9~),
          ${misc:Depends},
          ${shlibs:Depends}

Run locally

Try this locally (using the lintian-brush package):

debcheckout ruby-omniauth-oauth2
cd ruby-omniauth-oauth2
deb-scrub-obsolete

More details

Full run details