scrub-obsolete Package - systemsettings

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/systemsettings scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index e1a6b42..c9a792c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+systemsettings (4:5.20.5-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake and pkg-kde-tools.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 17 Mar 2021 01:11:12 -0000
+
 systemsettings (4:5.20.5-2) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index 7aaef46..aa6d3c1 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Scarlett Moore <sgmoore@kde.org>,
            Patrick Franz <patfra71@gmail.com>,
            Norbert Preining <norbert@preining.info>,
-Build-Depends: cmake (>= 3.0~),
+Build-Depends: cmake,
                debhelper-compat (= 13),
                extra-cmake-modules (>= 5.74.0~),
                gettext,
@@ -27,10 +27,10 @@ Build-Depends: cmake (>= 3.0~),
                libkf5widgetsaddons-dev (>= 5.74.0~),
                libkf5windowsystem-dev (>= 5.74.0~),
                libkf5xmlgui-dev (>= 5.74.0~),
-               pkg-kde-tools (>= 0.15.18~),
+               pkg-kde-tools,
                plasma-workspace-dev (>= 4:5.20.5~),
                qtbase5-dev (>= 5.15.0~),
-               qtdeclarative5-dev (>= 5.15.0~),
+               qtdeclarative5-dev (>= 5.15.0~)
 Standards-Version: 4.5.1
 Homepage: https://invent.kde.org/plasma/systemsettings
 Vcs-Browser: https://salsa.debian.org/qt-kde-team/kde/systemsettings

Run locally

Try this locally (using the lintian-brush package):

debcheckout systemsettings
cd systemsettings
deb-scrub-obsolete

More details

Full run details