scrub-obsolete Package - tcl8.6

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/tcl8.6 scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 4c84fb9..87f2a57 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+tcl8.6 (8.6.10+dfsg-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper.
+    + libtcl8.6: Drop versioned constraint on tcl8.6 in Conflicts.
+    + libtcl8.6: Drop versioned constraint on tcl8.6 in Replaces.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sun, 08 Nov 2020 02:43:49 -0000
+
 tcl8.6 (8.6.10+dfsg-1) unstable; urgency=medium
 
   * New upstream release.
diff --git a/debian/control b/debian/control
index f915605..258a0aa 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: libs
 Priority: optional
 Maintainer: Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>
 Uploaders: Sergei Golovan <sgolovan@debian.org>
-Build-Depends: debhelper (>= 10.0.0), dpkg-dev (>= 1.16.1~), zlib1g-dev
+Build-Depends: debhelper, dpkg-dev (>= 1.16.1~), zlib1g-dev
 Standards-Version: 4.4.1
 Homepage: http://www.tcl.tk/
 Vcs-Browser: https://salsa.debian.org/tcltk-team/tcl8.6
@@ -28,8 +28,7 @@ Priority: optional
 Architecture: any
 Pre-Depends: ${misc:Pre-Depends}
 Depends: tzdata, ${shlibs:Depends}, ${misc:Depends}
-Conflicts: tcl8.6 (<< 8.6.0-2), tcl74 (<= 7.4p3-2)
-Replaces: tcl8.6 (<< 8.6.0-2)
+Conflicts: , tcl74 (<= 7.4p3-2)
 Breaks: nsf (<< 2.2.0)
 Suggests: tcl8.6
 Provides: libtcl

Run locally

Try this locally (using the lintian-brush package):

debcheckout tcl8.6
cd tcl8.6
deb-scrub-obsolete

More details

Full run details