scrub-obsolete Package - tk8.6

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/tk8.6 scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 88e1257..577912b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+tk8.6 (8.6.11-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper.
+    + tk8.6: Drop versioned constraint on libtk-img in Conflicts.
+    + libtk8.6: Drop versioned constraint on libtk-img and tk8.6 in Conflicts.
+    + libtk8.6: Drop versioned constraint on tk8.6 in Replaces.
+    + tk8.6-doc: Drop versioned constraint on tk8.6 in Conflicts.
+    + tk8.6-doc: Drop versioned constraint on tk8.6 in Replaces.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 17 May 2021 00:52:16 -0000
+
 tk8.6 (8.6.11-2) unstable; urgency=medium
 
   * Drop unused Build-Depends: libxt-dev. (Closes: #981603)
diff --git a/debian/control b/debian/control
index ad62bd4..2dc855b 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: libs
 Priority: optional
 Maintainer: Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>
 Uploaders: Sergei Golovan <sgolovan@debian.org>
-Build-Depends: debhelper (>= 10.0.0), dpkg-dev (>= 1.16.1~), x11proto-core-dev,
+Build-Depends: debhelper, dpkg-dev (>= 1.16.1~), x11proto-core-dev,
  libx11-dev, libxss-dev, libxext-dev, libxft-dev,
  tcl8.6-dev (>= 8.6.8+dfsg-3~)
 Standards-Version: 4.5.1
@@ -17,7 +17,7 @@ Priority: optional
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Recommends: xterm | x-terminal-emulator
-Conflicts: tk40 (<= 4.0p3-2), libtk-img (<< 1.2.5)
+Conflicts: tk40 (<= 4.0p3-2)
 Multi-Arch: foreign
 Description: Tk toolkit for Tcl and X11 v8.6 - windowing shell
  Tk is a cross-platform graphical toolkit which provides the Motif
@@ -30,8 +30,7 @@ Priority: optional
 Architecture: any
 Pre-Depends: ${misc:Pre-Depends}
 Depends: libtcl8.6 (>= 8.6.0-2), ${shlibs:Depends}, ${misc:Depends}
-Conflicts: tk8.6 (<<8.6.0-2), tk40 (<= 4.0p3-2), libtk-img (<< 1.2.5)
-Replaces: tk8.6 (<<8.6.0-2)
+Conflicts: tk40 (<= 4.0p3-2)
 Suggests: tk8.6
 Provides: libtk
 Multi-Arch: same
@@ -63,8 +62,7 @@ Priority: optional
 Architecture: all
 Depends: ${misc:Depends}
 Suggests: tk8.6
-Conflicts: tkdoc, tk8.6 (<< 8.6.0-2)
-Replaces: tk8.6 (<< 8.6.0-2)
+Conflicts: tkdoc
 Provides: tkdoc
 Description: Tk toolkit for Tcl and X11 v8.6 - manual pages
  Tk is a cross-platform graphical toolkit which provides the Motif

Run locally

Try this locally (using the lintian-brush package):

debcheckout tk8.6
cd tk8.6
deb-scrub-obsolete

More details

Full run details