scrub-obsolete Package - tnetstring3

Ready changes

Diff

diff --git a/debian/changelog b/debian/changelog
index 34af03b..71a7d79 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+tnetstring3 (0.3.1-4) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since buster:
+    + Build-Depends: Drop versioned constraint on debhelper and dpkg-dev.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 09 Sep 2021 12:52:56 -0000
+
 tnetstring3 (0.3.1-3) unstable; urgency=medium
 
   * Build-depend on dh-python (Closes: #944948)
diff --git a/debian/control b/debian/control
index a152d82..61e4692 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: tnetstring3
 Section: python
 Priority: optional
 Maintainer: Jan Niehusmann <jan@debian.org>
-Build-Depends: debhelper (>= 8.0.0), python3-all-dev, dpkg-dev (>= 1.16.1~), python3-setuptools, dh-python
+Build-Depends: debhelper, python3-all-dev, python3-setuptools, dh-python
 Standards-Version: 4.1.4
 Homepage: https://github.com/carlopires/tnetstring3/
 Vcs-Git: https://salsa.debian.org/jan/tnetstring3.git

Run locally

Try this locally (using the package):

debcheckout tnetstring3
cd tnetstring3
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details