scrub-obsolete Package - upower

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/upower scrub-obsolete/main

Diff

diff --git a/debian/control b/debian/control
index 92e5740..c417371 100644
--- a/debian/control
+++ b/debian/control
@@ -6,9 +6,9 @@ Uploaders: Michael Biebl <biebl@debian.org>,
            Martin Pitt <mpitt@debian.org>,
 Build-Depends: debhelper-compat (= 12),
                dh-exec,
-               gobject-introspection (>= 0.9.12-4~),
+               gobject-introspection,
                gtk-doc-tools,
-               gettext (>= 0.19.8),
+               gettext,
                libgirepository1.0-dev (>= 0.10.7-1~),
                libglib2.0-dev (>= 2.36),
                libgudev-1.0-dev (>= 147) [linux-any],
@@ -59,7 +59,7 @@ Multi-Arch: same
 Pre-Depends: ${misc:Pre-Depends},
 Depends: ${misc:Depends},
          ${shlibs:Depends},
-Recommends: upower (>> 0.99),
+Recommends: upower,
 Description: abstraction for power management - shared library
  upower provides an interface to enumerate power sources on the system
  and control system-wide power management. Any application can access the

Run locally

Try this locally (using the lintian-brush package):

debcheckout upower
cd upower
deb-scrub-obsolete

More details

Full run details