scrub-obsolete Package - w3c-sgml-lib

Recent merge proposals

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/w3c-sgml-lib scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 7d6dcbf..01055fb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+w3c-sgml-lib (1.3-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper and xml-core.
+    + w3c-sgml-lib: Drop versioned constraint on w3c-markup-validator in Breaks.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 27 Feb 2021 15:06:01 -0000
+
 w3c-sgml-lib (1.3-1) unstable; urgency=low
 
   * New upstream release (Closes: #665298)
diff --git a/debian/control b/debian/control
index 6277980..801f560 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: w3c-sgml-lib
 Section: text
 Priority: optional
 Maintainer: Nicholas Bamber <nicholas@periapt.co.uk>
-Build-Depends: debhelper (>= 9.20120909), xml-core (>= 0.13+nmu2~),
+Build-Depends: debhelper, xml-core,
  libreadonly-perl, libxml-libxml-perl, libautodie-perl
 Standards-Version: 3.9.4
 Homepage: http://validator.w3.org/sgml-lib
@@ -12,7 +12,6 @@ Vcs-Browser: https://github.com/periapt/w3c-sgml-lib
 Package: w3c-sgml-lib
 Architecture: all
 Depends: ${misc:Depends}
-Breaks: w3c-markup-validator (<< 1.2+dfsg-6)
 Conflicts: w3c-dtd-xhtml
 Description: w3.org DTD and catalog files
  This package consists of all the definition files used by the 

Run locally

Try this locally (using the lintian-brush package):

debcheckout w3c-sgml-lib
cd w3c-sgml-lib
deb-scrub-obsolete

More details

Full run details