scrub-obsolete Package - wdm

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/wdm scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index ad39877..0bd3507 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,15 @@
 wdm (1.28-26) UNRELEASED; urgency=medium
 
+  [ Axel Beckert ]
   * Use --no-stop-on-upgrade instead of --no-restart-on-upgrade. The
     latter will become deprecated. Requested by nthykier in #959678.
   * Drop --no-restart-after-upgrade again and build-depend on at least
     debhelper 13.1 instead as it fixed #959678.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + wdm: Drop versioned constraint on debconf in Depends.
+
  -- Axel Beckert <abe@debian.org>  Tue, 05 May 2020 23:19:36 +0200
 
 wdm (1.28-25) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index b123e3f..22ce929 100644
--- a/debian/control
+++ b/debian/control
@@ -34,7 +34,7 @@ Rules-Requires-Root: no
 
 Package: wdm
 Architecture: any
-Depends: debconf (>= 1.5.20) | debconf-2.0,
+Depends: debconf | debconf-2.0,
          libpam-modules,
          libpam-runtime (>= 0.76-13.1),
          lsb-base (>= 3.0-6),

Run locally

Try this locally (using the lintian-brush package):

debcheckout wdm
cd wdm
deb-scrub-obsolete

More details

Full run details