scrub-obsolete Package - xotcl

Ready changes

Diff

diff --git a/debian/changelog b/debian/changelog
index 6624d05..b79ddc2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+xotcl (1.6.8-5) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since buster:
+    + Build-Depends: Drop versioned constraint on tcl-dev and tk-dev.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 06 Nov 2021 21:49:20 -0000
+
 xotcl (1.6.8-4) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index 7e5bae9..1c123e7 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: libs
 Priority: optional
 Maintainer: Tcl/Tk Debian Packagers <pkg-tcltk-devel@lists.alioth.debian.org>
 Uploaders: Stefan Sobernig <stefan.sobernig@wu-wien.ac.at>
-Build-Depends: debhelper (>= 9), quilt,  autotools-dev, tcl-dev (>= 8.6), tk-dev (>= 8.6), libexpat1-dev
+Build-Depends: debhelper (>= 9), quilt,  autotools-dev, tcl-dev, tk-dev, libexpat1-dev
 Standards-Version: 4.1.3
 Homepage: http://www.xotcl.org/
 Vcs-Browser: https://salsa.debian.org/tcltk-team/xotcl

Run locally

Try this locally (using the package):

debcheckout xotcl
cd xotcl
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details