Codebase list aspell-ar-large / scrub-obsolete/main debian / rules
scrub-obsolete/main

Tree @scrub-obsolete/main (Download .tar.gz)

rules @scrub-obsolete/mainraw · history · blame

#!/usr/bin/make -f

DICT_LANG = ar-large
BASEDIR = `pwd`/debian/aspell-ar-large

%:
	dh $@

override_dh_auto_configure:
	./configure
	cp ar.cwl ar-large.cwl
	cp debian/ar-large.dat .
	cp ar_affix.dat ar-large_affix.dat
	cp l-ar.cset l-ar-large.cset
	cp l-ar.cmap l-ar-large.cmap

override_dh_auto_clean:
	[ ! -f Makefile ] || $(MAKE) distclean
	rm -f Makefile
	rm -f ar-large.cwl
	rm -f ar-large.dat
	rm -f ar-large_affix.dat
	rm -f l-ar-large.cset
	rm -f l-ar-large.cmap
	dh_clean

override_dh_auto_install:
	cp debian/arabic-large.alias debian/ar-large.multi debian/ar-large.dat .
	$(MAKE) DESTDIR=$(BASEDIR) install
	rm -f $(BASEDIR)/usr/lib/aspell/ar-large.rws
	gzip -9cn ar-large.cwl > $(BASEDIR)/usr/share/aspell/ar-large.cwl.gz
	installdeb-aspell