Codebase list balboa / debian/2.0.0+ds-3 debian / rules
debian/2.0.0+ds-3

Tree @debian/2.0.0+ds-3 (Download .tar.gz)

rules @debian/2.0.0+ds-3raw · history · blame

#!/usr/bin/make -f

#export DH_VERBOSE = 1
export DH_GOPKG := github.com/DCSO/balboa
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DH_GOLANG_INSTALL_EXTRA := testdata

%:
	dh $@ --buildsystem=golang --with=golang

override_dh_auto_install:
	dh_auto_install -- --no-source

override_dh_auto_clean:
	dh_auto_clean
	rm -rf debian/man

override_dh_installsystemd:
	dh_installsystemd -p balboa balboa.service
	dh_installsystemd -p balboa-backend-common --no-enable --no-start \
	  --name=balboa-backend@ balboa-backend@.service

override_dh_auto_build:
	dh_auto_build
	mkdir -p debian/man
	find . -executable -wholename '*bin/balboa' -exec {} makeman --dir debian/man \;
	make -C backend
	help2man --no-discard-stderr -N -n 'RocksDB backend for balboa' \
	       	backend/balboa-rocksdb/build/balboa-rocksdb > debian/man/balboa-rocksdb.1
	help2man --no-discard-stderr -N -n 'Backend maintenance console for balboa' \
		backend/balboa-backend-console/build/balboa-backend-console > debian/man/balboa-backend-console.1