Codebase list bam / 73981b45-09bc-4692-b75d-9e02bc255b93/main debian / rules
73981b45-09bc-4692-b75d-9e02bc255b93/main

Tree @73981b45-09bc-4692-b75d-9e02bc255b93/main (Download .tar.gz)

rules @73981b45-09bc-4692-b75d-9e02bc255b93/mainraw · history · blame

#!/usr/bin/make -f

DPKG_EXPORT_BUILDFLAGS = 1
DPKG_EXPORT_BUILDTOOLS = nonempty
-include /usr/share/dpkg/buildflags.mk
include /usr/share/dpkg/buildtools.mk

%:
	dh $@

override_dh_auto_configure:
	# nothing to do

override_dh_auto_build:
	sh make_unix.sh
	python3 scripts/gendocs.py

override_dh_auto_install:
	# do nothing here

override_dh_auto_test:
	python3 scripts/test.py

override_dh_auto_clean:
	$(RM) bam docs/bam.html scripts/*.pyc
	$(RM) -r test_output
	$(RM) docs/depgraph.png