Codebase list ciftilib / debian/1.6.0-2 debian / patches / 0002-Fix-compilation-with-Boost-1.71.patch
debian/1.6.0-2

Tree @debian/1.6.0-2 (Download .tar.gz)

0002-Fix-compilation-with-Boost-1.71.patch @debian/1.6.0-2raw · history · blame

From: Giovanni Mascellani <gio@debian.org>
Date: Sat, 11 Jan 2020 15:44:14 +0100
Bug-Debian: https://bugs.debian.org/948665
Subject: Fix compilation with Boost 1.71.

Method file_string() is now obsolete and just calls string().
---
 src/CiftiFile.cxx | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--- a/src/CiftiFile.cxx
+++ b/src/CiftiFile.cxx
@@ -100,7 +100,7 @@ namespace
         return QFileInfo(mypath).absoluteFilePath();
 #else
 #ifdef CIFTILIB_BOOST_NO_FSV3
-	return filesystem::complete(AString_to_std_string(mypath)).file_string();
+	return filesystem::complete(AString_to_std_string(mypath)).string();
 #else
         return filesystem::absolute(AString_to_std_string(mypath)).native();
 #endif
@@ -113,7 +113,7 @@ namespace
         return QFileInfo(mypath).canonicalFilePath();
 #else
 #ifdef CIFTILIB_BOOST_NO_FSV3
-        return filesystem::complete(AString_to_std_string(mypath)).file_string();
+        return filesystem::complete(AString_to_std_string(mypath)).string();
 #else
 #ifdef CIFTILIB_BOOST_NO_CANONICAL
         filesystem::path temp = AString_to_std_string(mypath);