Codebase list csladspa / HEAD debian / rules
HEAD

Tree @HEAD (Download .tar.gz)

rules @HEADraw · history · blame

#!/usr/bin/make -f
# See debhelper(7) (uncomment to enable)
# output every command that modifies files on the build system.
#export DH_VERBOSE = 1


# see FEATURE AREAS in dpkg-buildflags(1)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all

%:
	dh $@ --buildsystem=cmake+ninja

override_dh_auto_test:
	# no tests

override_dh_auto_install:
	dh_auto_install
	mkdir -p $(CURDIR)/debian/csladspa/usr/lib/ladspa
	mv $(CURDIR)/debian/csladspa/usr/lib/csladspa64.so \
		$(CURDIR)/debian/csladspa/usr/lib/ladspa/csladspa64.so