Codebase list cyrus-sasl2 / 0c43acff-ece6-496a-822b-3c6d0c60692a/main debian / patches / 0001-automake-Define-LIBSASL_EXPORTS.patch
0c43acff-ece6-496a-822b-3c6d0c60692a/main

Tree @0c43acff-ece6-496a-822b-3c6d0c60692a/main (Download .tar.gz)

0001-automake-Define-LIBSASL_EXPORTS.patch @0c43acff-ece6-496a-822b-3c6d0c60692a/mainraw · history · blame

Origin: upstream, https://github.com/cyrusimap/cyrus-sasl/commit/18548eb9d477dc130a5a3de3585106a73b4b8341
From: Biswapriyo Nath <nathbappai@gmail.com>
Date: Tue, 13 Apr 2021 12:22:12 +0530
Subject: automake: Define LIBSASL_EXPORTS to link with exported DB functions.

Signed-off-by: Biswapriyo Nath <nathbappai@gmail.com>
---
 plugins/Makefile.am | 2 +-
 sasldb/Makefile.am  | 2 +-
 utils/Makefile.am   | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 7aff8fea..11d0e70e 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -49,7 +49,7 @@
 # CURRENT:REVISION:AGE
 plugin_version = 3:0:0
 
-AM_CPPFLAGS=-I$(top_srcdir)/include -I$(top_srcdir)/lib -I$(top_srcdir)/sasldb -I$(top_srcdir)/common -I$(top_builddir)/include
+AM_CPPFLAGS=-DLIBSASL_EXPORTS=1 -I$(top_srcdir)/include -I$(top_srcdir)/lib -I$(top_srcdir)/sasldb -I$(top_srcdir)/common -I$(top_builddir)/include
 AM_LDFLAGS = -module -export-dynamic -rpath $(plugindir) -version-info $(plugin_version) -no-undefined
 
 if BUILD_LIBOBJ
diff --git a/sasldb/Makefile.am b/sasldb/Makefile.am
index 13489451..97f4a5be 100644
--- a/sasldb/Makefile.am
+++ b/sasldb/Makefile.am
@@ -44,7 +44,7 @@
 # Note that this doesn't necessaraly follow the libsasl2 verison info
 sasl_version = 1:25:0
 
-AM_CPPFLAGS=-fPIC -I$(top_srcdir)/include -I$(top_builddir)/include @SASL_DB_INC@
+AM_CPPFLAGS=-DLIBSASL_EXPORTS=1 -fPIC -I$(top_srcdir)/include -I$(top_builddir)/include @SASL_DB_INC@
 
 extra_common_sources = db_none.c db_lmdb.c db_ndbm.c db_gdbm.c db_berkeley.c
 
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 6ffd8b99..99c49e1d 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -89,7 +89,7 @@ libsfsasl2_la_SOURCES =
 libsfsasl2_la_LIBADD = sfsasl.lo
 libsfsasl2_la_LDFLAGS = -version-info 1:0:0 -export-dynamic -rpath $(libdir)
 
-AM_CPPFLAGS=-I$(top_srcdir)/include -I$(top_builddir)/include @SASL_DB_INC@ -DPLUGINDIR='"${plugindir}"'
+AM_CPPFLAGS=-DLIBSASL_EXPORTS=1 -I$(top_srcdir)/include -I$(top_builddir)/include @SASL_DB_INC@ -DPLUGINDIR='"${plugindir}"'
 
 EXTRA_DIST = saslpasswd2.8 sasldblistusers2.8 pluginviewer.8 sfsasl.h sfsasl.c smtptest.c testsuite.c pluginviewer.c NTMakefile