Codebase list cyrus-sasl2 / 14991f28-9551-4988-ac45-514198f57230/main debian / patches / 0034-CVE-2019-19906.patch
14991f28-9551-4988-ac45-514198f57230/main

Tree @14991f28-9551-4988-ac45-514198f57230/main (Download .tar.gz)

0034-CVE-2019-19906.patch @14991f28-9551-4988-ac45-514198f57230/mainraw · history · blame

Origin: upstream, https://github.com/cyrusimap/cyrus-sasl/commit/dcc9f51cbd4ed622cfb0f9b1c141eb2ffe3b12f1
Bug: https://github.com/cyrusimap/cyrus-sasl/issues/587
Bug-Debian: https://bugs.debian.org/947043
Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2019-19906
From: Quanah Gibson-Mount <quanah@symas.com>
Date: Tue, 18 Feb 2020 19:05:12 +0000
Subject: Fix #587

Off by one error in common.c, CVE-2019-19906.

Thanks to Stephan Zeisberg for reporting
---
 lib/common.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/common.c b/lib/common.c
index bc3bf1df..9969d6aa 100644
--- a/lib/common.c
+++ b/lib/common.c
@@ -190,7 +190,7 @@ int _sasl_add_string(char **out, size_t *alloclen,
 
   if (add==NULL) add = "(null)";
 
-  addlen=strlen(add); /* only compute once */
+  addlen=strlen(add)+1; /* only compute once */
   if (_buf_alloc(out, alloclen, (*outlen)+addlen)!=SASL_OK)
     return SASL_NOMEM;