Codebase list cyrus-sasl2 / run/61f22fea-629d-4910-9079-88a1ebd9c68f/main debian / patches / 0002-Use-etc-sasldb2-instead-of-.-sasldb-in-the-testsuite.patch
run/61f22fea-629d-4910-9079-88a1ebd9c68f/main

Tree @run/61f22fea-629d-4910-9079-88a1ebd9c68f/main (Download .tar.gz)

0002-Use-etc-sasldb2-instead-of-.-sasldb-in-the-testsuite.patch @run/61f22fea-629d-4910-9079-88a1ebd9c68f/mainraw · history · blame

Forwarded: not-needed
From: Debian Cyrus SASL Team
 <pkg-cyrus-sasl2-debian-devel@lists.alioth.debian.org>
Date: Thu, 24 Mar 2016 11:35:03 +0100
Subject: Use /etc/sasldb2 instead of ./sasldb in the testsuite

---
 utils/testsuite.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/utils/testsuite.c b/utils/testsuite.c
index 12da7f7..9b2a6a7 100644
--- a/utils/testsuite.c
+++ b/utils/testsuite.c
@@ -461,9 +461,9 @@ int good_getopt(void *context __attribute__((unused)),
 	    *len = (unsigned) strlen("sasldb");
 	return SASL_OK;
     } else if (!strcmp(option, "sasldb_path")) {
-	*result = "./sasldb";
+	*result = "/etc/sasldb2";
 	if (len)
-	    *len = (unsigned) strlen("./sasldb");
+	    *len = (unsigned) strlen("/etc/sasldb2");
 	return SASL_OK;
     } else if (!strcmp(option, "canon_user_plugin")) {
 	*result = cu_plugin;
@@ -2925,7 +2925,7 @@ void notes(void)
 void usage(void)
 {
     printf("Usage:\n" \
-           " testsuite [-g name] [-s seed] [-r tests] -a -M\n" \
+           " sasltestsuite [-g name] [-s seed] [-r tests] -a -M\n" \
            "    g -- gssapi service name to use (default: host)\n" \
 	   "    r -- # of random tests to do (default: 25)\n" \
 	   "    a -- do all corruption tests (and ignores random ones unless -r specified)\n" \