Codebase list django-allauth / e7114bc8-2fd6-436e-92bb-010082b4e605/main debian / rules
e7114bc8-2fd6-436e-92bb-010082b4e605/main

Tree @e7114bc8-2fd6-436e-92bb-010082b4e605/main (Download .tar.gz)

rules @e7114bc8-2fd6-436e-92bb-010082b4e605/mainraw · history · blame

#!/usr/bin/make -f

export PYBUILD_NAME=django-allauth

%:
	dh $@ --with python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_build:
	cd allauth && django-admin compilemessages
	PYTHONPATH=. python3 -m sphinx -b html -d docs/.build/.doctrees -N docs docs/.build/html
	dh_auto_build

override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
	set -e; \
	for python in $(shell py3versions -r); do \
		PYTHONPATH="." DJANGO_SETTINGS_MODULE=test_settings $$python $(shell which django-admin) test allauth.tests;\
	done
endif