Codebase list emacs-deferred / 4b60f5e0-f890-4725-8c11-e7ee81abfed9/main debian / patches / 0003-comment-out-undercover.diff
4b60f5e0-f890-4725-8c11-e7ee81abfed9/main

Tree @4b60f5e0-f890-4725-8c11-e7ee81abfed9/main (Download .tar.gz)

0003-comment-out-undercover.diff @4b60f5e0-f890-4725-8c11-e7ee81abfed9/mainraw · history · blame

From: Lev Lamberov <dogsleg@debian.org>
Subject: Comment out undercover in tests

This patch comments out undercover in tests. The package
elpa-undercover is not a real dependency (it is used just to collect
tests statistics), so it's better to comment it out rather then add it
as a dependency to d/control. The main motivation is to fix
autopkgtest (otherwise autopkgtest fails because it cannot load
undercover.el)

Index: emacs-deferred/test/concurrent-test.el
===================================================================
--- emacs-deferred.orig/test/concurrent-test.el
+++ emacs-deferred/test/concurrent-test.el
@@ -19,10 +19,10 @@
 ;; How to run this test ?
 ;; $ emacs -L . -L $HOME/.emacs.d/elisp -batch -l deferred -l concurrent -l test-concurrent -f cc:test-all
 
-(require 'undercover)
-(undercover "concurrent.el"
-            (:send-report nil)
-            (:report-file "/tmp/undercover-report.json"))
+;; (require 'undercover)
+;; (undercover "concurrent.el"
+;;             (:send-report nil)
+;;             (:report-file "/tmp/undercover-report.json"))
 (require 'concurrent)
 (require 'cl-lib)
 (require 'pp)
Index: emacs-deferred/test/deferred-test.el
===================================================================
--- emacs-deferred.orig/test/deferred-test.el
+++ emacs-deferred/test/deferred-test.el
@@ -23,10 +23,10 @@
 
 
 (require 'ert)
-(require 'undercover)
-(undercover "deferred.el"
-            (:send-report nil)
-            (:report-file "/tmp/undercover-report.json"))
+;; (require 'undercover)
+;; (undercover "deferred.el"
+;;             (:send-report nil)
+;;             (:report-file "/tmp/undercover-report.json"))
 (require 'deferred)
 (require 'cl-lib)
 (require 'pp)