Codebase list fenrir / ce063036-2fb3-4e1b-8f69-6cf9cb655e8c/main debian / rules
ce063036-2fb3-4e1b-8f69-6cf9cb655e8c/main

Tree @ce063036-2fb3-4e1b-8f69-6cf9cb655e8c/main (Download .tar.gz)

rules @ce063036-2fb3-4e1b-8f69-6cf9cb655e8c/mainraw · history · blame

#!/usr/bin/make -f

%:
	dh $@ --with python3 --buildsystem=pybuild

override_dh_python3:
	dh_python3
	dh_python3 /usr/share/fenrirscreenreader

override_dh_install:
	dh_install
	dh_install config/settings/settings.conf /etc/fenrirscreenreader/settings
	sed -i -e '1s_#!/usr/bin/python$$_#!/usr/bin/python3_' $$(find debian -name \*.py)
	sed -i -e '1s_#!/bin/python_#!/usr/bin/python3_' $$(find debian -name \*.py)
	sed -i -e '1s_#!/bin/env python3_#!/usr/bin/python3_' $$(find debian -name \*.py)
	dh_install autostart/systemd/Debian/fenrir.service /lib/systemd/system