Codebase list globus-gass-copy / HEAD debian / rules
HEAD

Tree @HEAD (Download .tar.gz)

rules @HEADraw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

name = globus-gass-copy

export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed -Wl,-z,defs

INSTALLDIR = debian/tmp

_docdir = /usr/share/doc/lib$(name)-dev

%:
	dh $@

override_dh_autoreconf:
	dh_autoreconf --as-needed

override_dh_auto_configure:
	GLOBUS_VERSION=6.2 \
	dh_auto_configure -- \
	   --disable-static \
	   --includedir=/usr/include/globus \
	   --libexecdir=/usr/share/globus \
	   --docdir=$(_docdir)

override_dh_auto_test:
	GLOBUS_HOSTNAME=localhost dh_auto_test

override_dh_auto_install:
	dh_auto_install

	# Remove libtool archives (.la files)
	rm $(INSTALLDIR)/usr/lib/*/*.la

	# Remove installed license file
	rm $(INSTALLDIR)$(_docdir)/GLOBUS_LICENSE