Codebase list libgeotiff / debian/1.4.2.rc4-1.exp1 debian / rules
debian/1.4.2.rc4-1.exp1

Tree @debian/1.4.2.rc4-1.exp1 (Download .tar.gz)

rules @debian/1.4.2.rc4-1.exp1raw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

# Enable hardening build flags
export DEB_BUILD_MAINT_OPTIONS=hardening=+all

GEOTIFF_VERSION=$(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)-.*/\1/p' | sed -e 's/\+.*//; s/^[0-9]://')

%:
	dh $@ --with autoreconf --parallel

override_dh_autoreconf:
	dh_autoreconf ./autogen.sh

override_dh_clean:
	dh_clean libgeotiff.* xtiffio.h newgeo.tif

override_dh_install:
	$(RM) debian/*/usr/lib/*/libgeotiff.la
	dh_install --list-missing

override_dh_installchangelogs:
	dh_installchangelogs ChangeLog

override_dh_makeshlibs:
	# Forces failure ignoring to collect new symbols
	dh_makeshlibs -- -v$(GEOTIFF_VERSION)

override_dh_strip:
	dh_strip --dbg-package=libgeotiff2-dbg

get-orig-source:
	uscan --verbose --force-download --rename --repack --compression xz