Codebase list libisal / 05d95382-db26-4dd6-b014-8366535501cd/main debian / rules
05d95382-db26-4dd6-b014-8366535501cd/main

Tree @05d95382-db26-4dd6-b014-8366535501cd/main (Download .tar.gz)

rules @05d95382-db26-4dd6-b014-8366535501cd/mainraw · history · blame

#!/usr/bin/make -f

#export DH_VERBOSE = 1

export DPKG_GENSYMBOLS_CHECK_LEVEL=4

UPSTREAM_GIT := https://github.com/01org/isa-l.git
-include /usr/share/openstack-pkg-tools/pkgos.make

export DEB_BUILD_MAINT_OPTIONS = hardening=+all

%:
	dh $@

override_dh_installchangelogs:
	dh_installchangelogs Release_notes.txt

ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
override_dh_auto_test:
	$(MAKE) check
endif

override_dh_auto_configure:
	dh_auto_configure -- \
		--disable-static

override_dh_auto_install:
	dh_auto_install
	rm debian/tmp/usr/lib/*/*.la

override_dh_missing:
	dh_missing --fail-missing