Codebase list libsdl2-mixer / debian/2.5.1+dfsg-2 debian / patches / Document-that-the-master-volume-doesn-t-affect-music.patch
debian/2.5.1+dfsg-2

Tree @debian/2.5.1+dfsg-2 (Download .tar.gz)

Document-that-the-master-volume-doesn-t-affect-music.patch @debian/2.5.1+dfsg-2raw · history · blame

From: Sam Lantinga <slouken@libsdl.org>
Date: Fri, 27 May 2022 09:28:04 -0700
Subject: Document that the master volume doesn't affect music

Origin: upstream, 2.5.2, commit:6366d06f62e2a4baeb88751efd57522087f22266
---
 include/SDL_mixer.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/SDL_mixer.h b/include/SDL_mixer.h
index 55aaae2..09f870f 100644
--- a/include/SDL_mixer.h
+++ b/include/SDL_mixer.h
@@ -590,8 +590,8 @@ extern DECLSPEC int SDLCALL Mix_VolumeMusic(int volume);
 /* Get the current volume value in the range of 0-128 of a music stream */
 extern DECLSPEC int SDLCALL Mix_GetMusicVolume(Mix_Music *music);
 
-/* Set the master volume.
-   This did not affect the member variables of music, channel or chunck volume.
+/* Set the master volume for all channels.
+   This did not affect the member variables of channel or chunk volume.
    If the specified volume is -1, just return the current master volume.
 */
 extern DECLSPEC int SDLCALL Mix_MasterVolume(int volume);