Codebase list logbook / 48f20a6 debian / rules
48f20a6

Tree @48f20a6 (Download .tar.gz)

rules @48f20a6raw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

# Uncomment this to turn on verbose mode.
# export DH_VERBOSE=1

include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=$(DEB_SOURCE)

%:
	dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild

override_dh_auto_clean:
	dh_auto_clean
	rm -rf docs/_build
	rm -rf Logbook.egg-info

override_dh_auto_install:
	dh_auto_install
	# build the html pages for the -doc package
	set -ex; \
		cd docs; \
		make html

override_dh_auto_test:
# Run on autopkgtests

get-orig-source:
	@if [ ! -d "debian" ] ; then \
		echo 'Run this from the top directory of the Debian source' >&2; \
		exit 1; \
	fi
	uscan --noconf --verbose --rename --destdir=$(CURDIR) \
		--check-dirname-level=0 --force-download --download-version $(UVERSION)