Codebase list lwjgl / dbde013 debian / patches / add-missing-symbols-in-native-lib.patch
dbde013

Tree @dbde013 (Download .tar.gz)

add-missing-symbols-in-native-lib.patch @dbde013raw · history · blame

Description: Compile and add to library missing object files
 Some C files present in "src/native/common", and "src/native/linux"
 were not included in the native library build. This patch should include them
 back.
 .
 Also, when building the Debian package, the library "jawt", which is a
 dependency, was missing as well when building the native library.
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=912631#5
Last-Update: 2018-12-26

--- lwjgl-2.9.3+dfsg.orig/platform_build/linux_ant/build.xml
+++ lwjgl-2.9.3+dfsg/platform_build/linux_ant/build.xml
@@ -6,7 +6,7 @@
 	<property name="libname64" value="liblwjgl64.so"/>
 	<property name="libs32" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -lpthread -L${java.home}/lib/i386 -ljawt" />
 	<property name="libs64" value="-L/usr/X11R6/lib64 -L/usr/X11/lib64 -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -lpthread -L${java.home}/lib/amd64 -ljawt" />
-	<property name="libs" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXcursor -lXrandr -lXxf86vm -L${java.home}/lib/${os.arch}" />
+	<property name="libs" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXcursor -lXrandr -lXxf86vm -L${java.home}/lib/${os.arch} -ljawt" />
 	<property name="cflags32" value="-O2 -Wall -c -fPIC -std=c99 -Wunused"/>
 
 	<target name="clean">
@@ -148,8 +148,12 @@
 			<arg value="-I${native}/linux/opengl"/>
 			<mapper type="glob" from="*.c" to="*.o"/>
 			<fileset dir="${native}/linux" includes="*.c"/>
+			<fileset dir="${native}/linux/opengl" includes="*.c"/>
 			<fileset dir="${native}/generated" includes="*.c"/>
-			<fileset dir="${native}/common" includes="*.c"/>
+			<fileset dir="${native}/common" includes="**/*.c" excludes="opengles/**/*"/>
+			<fileset dir="${native}/generated/openal" includes="*.c"/>
+			<fileset dir="${native}/generated/opencl" includes="*.c"/>    		
+			<fileset dir="${native}/generated/opengl" includes="*.c"/>
 		</apply>
 		<apply dir="." parallel="true" executable="gcc" failonerror="true">
 			<srcfile/>