Codebase list metche / debian/metche_1%1.2.2-3 debian / patches / 0001-Bypass-root-s-mutt-configuration-file.patch
debian/metche_1%1.2.2-3

Tree @debian/metche_1%1.2.2-3 (Download .tar.gz)

0001-Bypass-root-s-mutt-configuration-file.patch @debian/metche_1%1.2.2-3raw · history · blame

From: intrigeri <intrigeri@boum.org>
Date: Fri, 5 Oct 2012 19:56:13 +0200
Subject: Bypass root's mutt configuration file.

In case the root user has configured mutt, in their $HOME, for their own
interactive use, we don't want these tweaks to impact the non-interactive use
metche makes of mutt in any way.

In case the administrator wants to configure mutt for interactive *and*
non-interactive use, they'd better edit its system-wide configuration file.

As mentioned by Andreas Beckmann, a mutt configuration file for the root user
may trigger more occurrences of Debian bug #657071 than needed :)
---
 metche |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/metche b/metche
index 4bf511c..ef1983e 100755
--- a/metche
+++ b/metche
@@ -82,7 +82,7 @@ add_header() {
 _mail() {
     local subject="$1"
     if which mutt > /dev/null ; then
-        LC_ALL="$LOCALE" mutt -s "$subject" "$EMAIL_ADDRESS"
+        LC_ALL="$LOCALE" mutt -F/dev/null -s "$subject" "$EMAIL_ADDRESS"
     elif which mail > /dev/null ; then
         LC_ALL="$LOCALE" mail -s "$subject" "$EMAIL_ADDRESS"
     elif [ -x /usr/sbin/sendmail ]; then