Codebase list mozc / b1628d0 debian / patches / mozc-el-not-suggest-in-minibuffer-fixed.patch
b1628d0

Tree @b1628d0 (Download .tar.gz)

mozc-el-not-suggest-in-minibuffer-fixed.patch @b1628d0raw · history · blame

# http://code.google.com/p/mozc/issues/detail?id=51
# irieshinsuke

=== modified file 'unix/emacs/mozc.el'
--- a/unix/emacs/mozc.el	2010-10-10 05:46:39 +0000
+++ b/unix/emacs/mozc.el	2010-10-11 23:35:23 +0000
@@ -439,8 +439,10 @@
 (defsubst mozc-cand-echo-area-update (candidates)
   "Update the candidate list in the echo area.
 CANDIDATES must be the candidates field in a response protobuf."
-  (let (message-log-max)
-    (message "%s" (mozc-cand-echo-area-make-contents candidates))))
+  (unless (and (minibufferp)
+               (eq (mozc-protobuf-get candidates 'category) 'suggestion))
+    (let (message-log-max)
+      (message "%s" (mozc-cand-echo-area-make-contents candidates)))))
 
 (defun mozc-cand-echo-area-make-contents (candidates)
   "Make a list of candidates as an echo area message.