Codebase list mozc / debian/0.11.svn13-1 debian / patches / protobuf.patch
debian/0.11.svn13-1

Tree @debian/0.11.svn13-1 (Download .tar.gz)

protobuf.patch @debian/0.11.svn13-1raw · history · blame

# Copyright Nobuhiro Iwamatsu <iwamatsu@debian.org>
#
# Disable protbuf build and replace to debian package

--- a/build_tools/primitive_tools/primitive_tools.gyp	2010-05-12 05:03:47.000000000 +0900
+++ b/build_tools/primitive_tools/primitive_tools.gyp	2010-05-12 05:03:57.000000000 +0900
@@ -39,7 +39,6 @@
       'dependencies': [
         '../../converter/converter.gyp:install_gen_pos_data_main',
         '../../prediction/prediction.gyp:install_gen_suggestion_filter_main',
-        '../../protobuf/protobuf.gyp:install_protoc',
       ],
     },
   ],
--- a/usage_stats/usage_stats.gyp	2010-05-13 06:49:56.000000000 +0900
+++ b/usage_stats/usage_stats.gyp	2010-05-13 06:50:03.000000000 +0900
@@ -42,7 +42,6 @@
         'usage_stats.cc',
       ],
       'dependencies': [
-        '../protobuf/protobuf.gyp:protobuf',
         '../base/base.gyp:base',
         '../net/net.gyp:net',
         '../storage/storage.gyp:storage',
--- a/ipc/ipc.gyp	2010-05-13 06:48:53.000000000 +0900
+++ b/ipc/ipc.gyp	2010-05-13 06:49:14.000000000 +0900
@@ -47,7 +47,6 @@
         'win32_ipc.cc',
       ],
       'dependencies': [
-        '../protobuf/protobuf.gyp:protobuf',
         '../base/base.gyp:base',
         'genproto_ipc',
       ],
--- a/session/session.gyp	2010-05-13 06:56:40.000000000 +0900
+++ b/session/session.gyp	2010-05-13 06:56:55.000000000 +0900
@@ -50,7 +50,6 @@
         'session_watch_dog.cc',
       ],
       'dependencies': [
-        '../protobuf/protobuf.gyp:protobuf',
         '../base/base.gyp:base',
         '../client/client.gyp:client',
         '../composer/composer.gyp:composer',
@@ -131,7 +130,6 @@
         '<(proto_out_dir)/<(relative_dir)/state.pb.cc',
       ],
       'dependencies': [
-        '../protobuf/protobuf.gyp:protobuf',
         'genproto_session'
       ],
     },
--- a/gyp/common.gypi	2010-05-13 06:24:09.000000000 +0900
+++ b/gyp/common.gypi	2010-05-13 06:24:32.000000000 +0900
@@ -288,7 +288,7 @@
       '<(DEPTH)/third_party/breakpad/src',
       '<(SHARED_INTERMEDIATE_DIR)',
       '<(SHARED_INTERMEDIATE_DIR)/proto_out',
-      '../protobuf/files/src',
+      '/usr/include',
     ],
     'conditions': [
       ['OS=="win"', {
--- a/unix/ibus/ibus.gyp	2010-05-13 05:00:43.000000000 +0900
+++ b/unix/ibus/ibus.gyp	2010-05-13 06:03:06.000000000 +0900
@@ -54,7 +54,8 @@
       ' <!@(pkg-config --cflags-only-I ibus-1.0)'
     ],
     'ibus_libraries': [
-      ' <!@(pkg-config --libs ibus-1.0)'
+      ' <!@(pkg-config --libs ibus-1.0)',
+      '/usr/lib/libprotobuf.a',
     ],
     'ibus_ldflags': [
       ' <!@(pkg-config --libs-only-L ibus-1.0)'