Codebase list orafce / cf4d217 debian / patches / git-sqy_yyerror.patch
cf4d217

Tree @cf4d217 (Download .tar.gz)

git-sqy_yyerror.patch @cf4d217raw · history · blame

From a525592a848cda759053a63e99b4463b1a00a892 Mon Sep 17 00:00:00 2001
From: Pavel Stehule <pavel.stehule@gooddata.com>
Date: Mon, 25 Aug 2014 15:09:42 +0200
Subject: [PATCH] fix broken definition of orafce_sql_yyerror function

---
 plvlex.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/plvlex.c b/plvlex.c
index ce8b66b..1da3179 100644
--- a/plvlex.c
+++ b/plvlex.c
@@ -37,7 +37,7 @@ typedef struct {
 PG_FUNCTION_INFO_V1(plvlex_tokens);
 
 extern int      orafce_sql_yyparse();
-extern void orafce_sql_yyerror(const char *message);
+extern void orafce_sql_yyerror(List **result, const char *message);
 extern void orafce_sql_scanner_init(const char *str);
 extern void orafce_sql_scanner_finish(void);
 
@@ -207,7 +207,7 @@ plvlex_tokens(PG_FUNCTION_ARGS)
 
 		orafce_sql_scanner_init(CSTRING(src));
 		if (orafce_sql_yyparse(&lexems) != 0)
-			orafce_sql_yyerror("bogus input");
+			orafce_sql_yyerror(NULL, "bogus input");
 
 		orafce_sql_scanner_finish();
 
-- 
2.1.0