Codebase list powerdevil / 4576e2a1-9cf0-4f00-96d5-3e489bfae7a5/main debian / rules
4576e2a1-9cf0-4f00-96d5-3e489bfae7a5/main

Tree @4576e2a1-9cf0-4f00-96d5-3e489bfae7a5/main (Download .tar.gz)

rules @4576e2a1-9cf0-4f00-96d5-3e489bfae7a5/mainraw · history · blame

#!/usr/bin/make -f

export DEB_BUILD_MAINT_OPTIONS = hardening=+all

DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)

libpkgs_gen_strict_local_shlibs = $(libpkgs_all_packages)
include /usr/share/pkg-kde-tools/qt-kde-team/2/library-packages.mk

%:
	dh $@ --with kf5,pkgkde_symbolshelper --buildsystem kf5 --without build_stamp

override_dh_gencontrol-arch: libpkgs_gen_strict_local_shlibs
	dh_gencontrol -a

override_dh_installdeb:
	sed 's/#DEB_HOST_MULTIARCH#/$(DEB_HOST_MULTIARCH)/' \
	    debian/powerdevil.postinst.in > debian/powerdevil.postinst
	dh_installdeb