Codebase list python-cbor / a642b92 debian / patches / missing-member-m_reload-on-pymoduledef-py3-5.patch
a642b92

Tree @a642b92 (Download .tar.gz)

missing-member-m_reload-on-pymoduledef-py3-5.patch @a642b92raw · history · blame

Author: Agustin Henze <tin@debian.org>
Bug-Debian: https://bugs.debian.org/800888

---

--- python-cbor-0.1.24.orig/c/cbormodule.c
+++ python-cbor-0.1.24/c/cbormodule.c
@@ -1468,7 +1468,11 @@ PyInit__cbor(void)
     modef.m_doc = NULL;
     modef.m_size = 0;
     modef.m_methods = CborMethods;
-    modef.m_reload = NULL;
+#if PY_MINOR_VERSION >= 5
+    modef.m_slots = NULL,
+#else
+    modef.m_reload = NULL,
+#endif
     modef.m_traverse = NULL;
     modef.m_clear = NULL;
     modef.m_free = NULL;