Codebase list python-werkzeug / debian/2.0.1+dfsg1-2 debian / rules
debian/2.0.1+dfsg1-2

Tree @debian/2.0.1+dfsg1-2 (Download .tar.gz)

rules @debian/2.0.1+dfsg1-2raw · history · blame

#!/usr/bin/make -f

# Copyright 2009, Noah Slater <nslater@tumbolia.org>

# Copying and distribution of this file, with or without modification, are
# permitted in any medium without royalty provided the copyright notice and this
# notice are preserved.

export PYBUILD_NAME=werkzeug
export PYBUILD_TEST_PYTEST=1
export PYBUILD_TEST_ARGS="-k not test_windows_get_args_for_reloading and not test_basic and not test_server and not test_ssl_dev_cert and not test_ssl_object and not test_reloader_sys_path and not test_chunked_encoding and not test_untrusted_host and not test_double_slash_path and not test_500_error and not test_wrong_protocol and not test_content_type_and_length and not test_multiple_headers_concatenated and not test_multiline_header_folding and not test_http_proxy"

%:
	dh $@ --with python3,sphinxdoc --buildsystem pybuild

override_dh_auto_clean:
	make -C docs clean
	rm -rf build Werkzeug.egg-info/
	#find $(CURDIR) \( -name '\._*' -o -name '\.DS_Store' \) -delete
	dh_auto_clean

override_dh_auto_test:
	set -ex; \
		memcached -p 11211 -l 127.0.0.1 & \
		trap "kill $$! || true" EXIT; \
		LC_ALL=C.UTF-8 dh_auto_test; \

override_dh_fixperms:
	find debian/ -name '*\.png' -exec chmod -x '{}' \;
	dh_fixperms

override_dh_installdocs:
	dh_installdocs --doc-main-package=python-werkzeug-doc -ppython-werkzeug-doc
	dh_installdocs

override_dh_installexamples:
	dh_installexamples --doc-main-package=python-werkzeug-doc -ppython-werkzeug-doc

override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
	PYTHONPATH=src python3 -m sphinx -b html docs/ debian/python-werkzeug-doc/usr/share/doc/python-werkzeug-doc/html/
	dh_sphinxdoc
endif