Codebase list ruby-gitlab / 488646b debian / patches / drop-git-ls-files.patch
488646b

Tree @488646b (Download .tar.gz)

drop-git-ls-files.patch @488646braw · history · blame

Description: Drop git ls-files in .gemspec
 Replace the git ls-files with Dir.glob as build is not in git directory
Author: Sophie Brun <sophie@freexian.com>
Last-Update: 2017-09-07
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/gitlab.gemspec
+++ b/gitlab.gemspec
@@ -12,7 +12,7 @@ Gem::Specification.new do |gem|
   gem.summary       = %q{A Ruby wrapper and CLI for the GitLab API}
   gem.homepage      = "https://github.com/narkoz/gitlab"
 
-  gem.files         = `git ls-files`.split($/)
+  gem.files         = Dir.glob('**/*')
   gem.bindir        = "exe"
   gem.executables   = gem.files.grep(%r{^exe/}) { |f| File.basename(f) }
   gem.test_files    = gem.files.grep(%r{^(test|spec|features)/})