Codebase list ruby-gitlab / acc1a81 debian / patches / drop-git-ls-files.patch
acc1a81

Tree @acc1a81 (Download .tar.gz)

drop-git-ls-files.patch @acc1a81raw · history · blame

Description: Drop git ls-files in .gemspec
 Replace the git ls-files with Dir.glob as build is not in git directory
Author: Sophie Brun <sophie@freexian.com>
Last-Update: 2018-08-20
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/gitlab.gemspec
+++ b/gitlab.gemspec
@@ -13,7 +13,7 @@ Gem::Specification.new do |gem|
   gem.summary       = 'A Ruby wrapper and CLI for the GitLab API'
   gem.homepage      = 'https://github.com/narkoz/gitlab'
 
-  gem.files         = `git ls-files`.split($/)
+  gem.files         = Dir.glob('**/*')
                                     .grep_v(/^spec/) -
                       %w[Dockerfile docker-compose.yml docker.env .travis.yml
                          .rubocop.yml .dockerignore]