Codebase list rust-libslirp / 6310ab10-2c91-4cc6-b8e4-8a33042f3195/main src / libslirp / debian / patches / enable-all-by-default.patch
6310ab10-2c91-4cc6-b8e4-8a33042f3195/main

Tree @6310ab10-2c91-4cc6-b8e4-8a33042f3195/main (Download .tar.gz)

enable-all-by-default.patch @6310ab10-2c91-4cc6-b8e4-8a33042f3195/mainraw · history · blame

Index: libslirp/Cargo.toml
===================================================================
--- libslirp.orig/Cargo.toml
+++ libslirp/Cargo.toml
@@ -25,7 +25,7 @@ repository = "https://gitlab.freedesktop
 
 [[bin]]
 name = "libslirp-helper"
-required-features = ["default", "helper"]
+required-features = ["default"]
 
 [[test]]
 name = "test-ip"
@@ -88,5 +88,4 @@ optional = true
 version = "0.8.0"
 
 [features]
-default = ["mio", "mio-extras", "ipnetwork", "structopt", "slab"]
-helper = ["libc", "zbus", "nix", "libsystemd", "url", "lazy_static", "zvariant", "enumflags2"]
+default = ["mio", "mio-extras", "ipnetwork", "structopt", "slab", "libc", "zbus", "nix", "libsystemd", "url", "lazy_static", "zvariant", "enumflags2"]