Codebase list rust-stfu8 / 82e12f0c-2329-4e87-b28d-bb7ca3cca764/main src / packed-simd / debian / patches / Remove-x86_m8x8_sse_impl-macro.diff
82e12f0c-2329-4e87-b28d-bb7ca3cca764/main

Tree @82e12f0c-2329-4e87-b28d-bb7ca3cca764/main (Download .tar.gz)

Remove-x86_m8x8_sse_impl-macro.diff @82e12f0c-2329-4e87-b28d-bb7ca3cca764/mainraw · history · blame

commit 950903a66950eaff745b0a029f2051d305df1c22
Author: Justus K <justus.k@protonmail.com>
Date:   Tue Sep 22 15:36:03 2020 +0200

    Remove `x86_m8x8_sse_impl` macro

diff --git a/src/codegen/reductions/mask/x86/sse.rs b/src/codegen/reductions/mask/x86/sse.rs
index 7482f94..eb1ef7f 100644
--- a/src/codegen/reductions/mask/x86/sse.rs
+++ b/src/codegen/reductions/mask/x86/sse.rs
@@ -34,35 +34,3 @@ macro_rules! x86_m32x4_sse_impl {
         }
     };
 }
-
-macro_rules! x86_m8x8_sse_impl {
-    ($id:ident) => {
-        impl All for $id {
-            #[inline]
-            #[target_feature(enable = "sse")]
-            unsafe fn all(self) -> bool {
-                #[cfg(target_arch = "x86")]
-                use crate::arch::x86::_mm_movemask_pi8;
-                #[cfg(target_arch = "x86_64")]
-                use crate::arch::x86_64::_mm_movemask_pi8;
-                // _mm_movemask_pi8(a) creates an 8bit mask containing the most
-                // significant bit of each byte of `a`. If all bits are set,
-                // then all 8 lanes of the mask are true.
-                _mm_movemask_pi8(crate::mem::transmute(self))
-                    == u8::max_value() as i32
-            }
-        }
-        impl Any for $id {
-            #[inline]
-            #[target_feature(enable = "sse")]
-            unsafe fn any(self) -> bool {
-                #[cfg(target_arch = "x86")]
-                use crate::arch::x86::_mm_movemask_pi8;
-                #[cfg(target_arch = "x86_64")]
-                use crate::arch::x86_64::_mm_movemask_pi8;
-
-                _mm_movemask_pi8(crate::mem::transmute(self)) != 0
-            }
-        }
-    };
-}