Codebase list splix / debian/2.0.0+svn293-1 debian / patches / 0001-Fix-alignment-problem-on-armel.patch
debian/2.0.0+svn293-1

Tree @debian/2.0.0+svn293-1 (Download .tar.gz)

0001-Fix-alignment-problem-on-armel.patch @debian/2.0.0+svn293-1raw · history · blame

From: Luca Niccoli <lultimouomo@gmail.com>
Date: Sun, 12 Jun 2011 15:30:15 +0200
Subject: Fix alignment problem on armel

---
 src/qpdl.cpp |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/src/qpdl.cpp b/src/qpdl.cpp
index 64190ee..94e6ddb 100644
--- a/src/qpdl.cpp
+++ b/src/qpdl.cpp
@@ -33,7 +33,7 @@ static bool _renderBand(const Request& request, const Band* band, bool mono)
 {
     unsigned long version, subVersion, size, dataSize, checkSum;
     bool color, headerSent=false;
-    unsigned char header[0x20];
+    unsigned char header[0x20] __attribute__((aligned(4)));
     const BandPlane *plane;
 
     version = request.printer()->qpdlVersion();
--