Codebase list xapp / upstream/1.6.2 debian / changelog
upstream/1.6.2

Tree @upstream/1.6.2 (Download .tar.gz)

changelog @upstream/1.6.2raw · history · blame

xapp (1.6.2) tricia; urgency=medium

  [ Eli Schwartz ]
  * mate applet: fix configuring
  * mate applet: fix regression in install location
  * debian: fixup changed file locations

  [ Michael Webster ]
  * mate-xapp-status-applet.py: handle a null icon name correctly.
  * test-scripts: have xapp-status-applet sort icons in the same manner the real applets do (symbolic to the right, then by alpha process name).
  * xapp-status-icon.c: Keep an account of button presses so an orphan release doesn't activate or pop up a menu.
  * xapp-status-icon: Track and notify changes in types of support for the icon - notify when a status icon is picked up by a native applet, a traditional system tray, or is not being picked up by anything.
  * xapp-status-icon.c: Replace g_enum_to_string with a custom function, this isn't available with lmde's glib.

 -- Clement Lefebvre <root@linuxmint.com>  Fri, 22 Nov 2019 10:36:41 +0000

xapp (1.6.1) tricia; urgency=medium

  [ Michael Webster ]
  * xapp-status-icon: Add a function to check for the existence of any active status applets.

 -- Clement Lefebvre <root@linuxmint.com>  Wed, 13 Nov 2019 17:33:22 +0100

xapp (1.6.0) tricia; urgency=medium

  [ Clement Lefebvre ]
  * Implement XAppStatusIcon (#67)

  [ James Ross ]
  * libxapp: cleanup compile warnings (#69)

  [ Michael Webster ]
  * status icons: Add a monitor class for applets - XAppStatusIconMonitor, (#70)
  * test-scripts: add a status-icon-via-libappindicator script.
  * xapp-status-icon.c: Remove leftover debug line
  * xapp-status-icon: When a menu is provided to XAppStatusIcon, handle positioning and showing it internally instead of requiring the application to do it.
  * xapp-status-icon.c: Use G_ class macros to cleanup header file, fix xapp_status_icon_get_menu()  (copy/paste error).
  * Add some useful build C-flags, fix test script exec bit.

  [ Clement Lefebvre ]
  * Add API reference in docs/reference/
  * Set theme jekyll-theme-architect
  * README: Add link to API reference

  [ Michael Webster ]
  * xapp-status-icon.c: Emit 'activate' during fallback status icon activation.
  * docs: Generate html automatically

  [ Stephen Collins ]
  * xapp-icon-chooser-dialog.c: Remove unused variable
  * icon chooser dialog: add default_icon property
  * icon chooser dialog: add *_add_custom_category () function

  [ Michael Webster ]
  * Add a Mate status applet (#72)
  * xapp-status-icon.c: Refactor event handling.

  [ Stephen Collins ]
  * xapp-icon-chooser-dialog.c: prevent segfault on non-existent icon name (#76)

  [ Clement Lefebvre ]
  * IconChooserButton: Add the ability to set the default category (#77)

  [ Stephen Collins ]
  * xapp-icon-chooser-button.c: add missing dispose method (#78)

  [ Michael Webster ]
  * mate-xapp-status-applet.py: Make improvements to event handling and widget appearance during clicks.
  * Add a custom install script for installing the generated header file.
  * Add i18n for the mate applet.
  * mate applet: Add an about window, use more appropriate install locations, move build replacement strings to a separate imported file.
  * xapp-status-icon.c: During async ops, when checking for cancellation, use the error code, as the cancellable may have reset in the interim, but the code will be correct.

  [ Michael Webster ]
  * status icons: Support multiple icons from the same process.

  [ Clement Lefebvre ]
  * Revert "docs: Generate html automatically"
  * Add a makedoc script to update docs/reference
  * Update reference docs

  [ Stephen Collins ]
  * xapp-icon-chooser-dialog.c: color the symbolic icons properly and fix hidpi (#79)

  [ Clement Lefebvre ]
  * l10n: Update POT

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 12 Nov 2019 11:12:12 +0100

xapp (1.4.9) tina; urgency=medium

  [ Michael Webster ]
  * Fix a couple of copy/paste mistakes.
  * xapp-icon-chooser-button.c: Only create the chooser dialog when needed.

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 20 Aug 2019 10:52:32 +0200

xapp (1.4.8) tina; urgency=medium

  * l10n: Update translations

 -- Clement Lefebvre <root@linuxmint.com>  Wed, 10 Jul 2019 11:10:06 +0200

xapp (1.4.7) tina; urgency=medium

  * l10n: Update translations

 -- Clement Lefebvre <root@linuxmint.com>  Sun, 23 Jun 2019 15:24:11 +0200

xapp (1.4.6) tina; urgency=medium

  [ Stephen Collins ]
  * xapp-icon-chooser-button.c: make dialog inherit modal state (#64)

 -- Clement Lefebvre <root@linuxmint.com>  Fri, 14 Jun 2019 12:00:33 +0100

xapp (1.4.5) tessa; urgency=medium

  * l10n: Update translations

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 11 Dec 2018 14:21:26 +0000

xapp (1.4.4) tessa; urgency=medium

  * Update translations

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 27 Nov 2018 18:16:32 +0000

xapp (1.4.3) tessa; urgency=medium

  [ Michael Webster ]
  * xapp-icon-chooser-dialog.c: Don't deep copy the category's icon list, just shallow copy and only free the strings once.  This is faster.

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 27 Nov 2018 17:24:54 +0000

xapp (1.4.2) tessa; urgency=medium

  [ Michael Webster ]
  * XAppGtkWindow: make derivable type.
  * xapp-icon-chooser-dialog: use XAppGtkWindow as a parent class, make the default window size slightly taller to prevent a category scroll bar under typical situations, remove the skip-taskbar hint in the test script.
  * xapp-gtk-window.c: Fix previous commit, initialize priv.
  * xapp-icon-chooser-dialog.c: Give the window the title 'Choose an icon'.
  * various improvements (#61)

  [ Clement Lefebvre ]
  * l10n: Update POT

  [ Michael Webster ]
  * xapp-icon-chooser-dialog.c: Only display icons that belong to contexts.

 -- Clement Lefebvre <root@linuxmint.com>  Mon, 19 Nov 2018 10:03:21 +0000

xapp (1.4.1) tessa; urgency=medium

  [ Stephen Collins ]
  * icon chooser dialog: Prevent the dialog from being destroyed when the window close button is clicked. This was causing an issue where the dialog will not reopen in some cases. (#56)
  * icon chooser button: fix image not updating when the icon property is set (#57)
  * icon chooser dialog: initialize the default value for the allow_paths property. it was causing file paths to not work when the property wasn't set, even though the browse button was showing (#59)
  * icon chooser button: prevent string pointer issues when calling icon_… (#58)
  * icon chooser button: enforce image size when using paths

  [ Michael Webster ]
  * xapp-icon-chooser-button.h: add missing public method and fix annotation for it.

 -- Clement Lefebvre <root@linuxmint.com>  Mon, 12 Nov 2018 15:13:01 +0000

xapp (1.4.0) tessa; urgency=medium

  [ JosephMcc ]
  * Add an XAppStackSidebar widget (#45)
  * stack-sidear: Simplify a bit
  * stack-sidebar: Allow using in Glade

  [ Michael Webster ]
  * xapp-stack-sidebar.c: Set our internal children visible during construction.

  [ JosephMcc ]
  * icons: Add new icons for the nemo preferences window
  * prefs-window: Use XAppStackSidebar

  [ Stephen Collins ]
  * Add an icon chooser dialog (#51)

  [ JosephMcc ]
  * icon-chooser: Do a bit of restyling (#52)

  [ Fabio Fantoni ]
  * Improve debian packaging (#42)

  [ Stephen Collins ]
  * fix segfault in icon chooser dialog and ensure a category is always selected (#54)
  * Add an icon chooser button. Displays an image of the icon and opens the icon chooser dialog on click. (#53)

  [ JosephMcc ]
  * prefs-window: Restyle to better match other dialogs (#55)

  [ Michael Webster ]
  * xapp-icon-chooser-dialog: include the generated enums header in the .c file so it does not break C application compilation.
  * xapp-icon-chooser-dialog: Add xapp_icon_chooser_dialog_add_button().

  [ Clement Lefebvre ]
  * l10n: Add makepot and de-couple POT from build system

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 30 Oct 2018 15:26:24 +0000

xapp (1.2.2) tara; urgency=medium

  [ Fabio Fantoni ]
  * circleci: remove mint18 job (#41)

  [ Michael Webster ]
  * xapp-gtk-window.c: Check for x11 at a more appropriate time.

  [ Clement Lefebvre ]
  * Pastebin: Replace gist with termbin

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 17 Jul 2018 09:35:34 +0200

xapp (1.2.1) tara; urgency=medium

  [ Michael Webster ]
  * icons: Add category-search-symbolic

 -- Clement Lefebvre <root@linuxmint.com>  Sun, 06 May 2018 14:34:17 +0100

xapp (1.2.0) tara; urgency=medium

  [ Clement Lefebvre ]
  * Add CI configuration

  [ Michael Webster ]
  * Build: Switch to Meson (#34)
  * docs/meson.build: split mkdb args properly. (fixes arch build)
  * Fix post-install script shebang, remove the schema file from translation tracking.
  * build: make docs optional, but enabled in debian build.  Add deprecated warnings option as well.
  * xapp-gtk-window.c: use gdk_error_trap_pop_ignored to quiet build warning.
  * xapp-gtk-window.c: Skip x11 calls if we're not running an x session.
  * xapp-gtk-window.c: only do an x11 check once, cache the result.

  [ JosephMcc ]
  * prefs-window: Remove a stray separator

  [ Michael Webster ]
  * build: Fix pkg-config generation to require header-file-included libs (fixes CI build for nemo)

  [ NikoKrause ]
  * Add media-mount-symbolic icon (#37)
  * extract/compress icons for nemo-fileroller (#38)

  [ Fabio Fantoni ]
  * debian: small improvements about python
  * debian: wrap-and-sort -bst
  * update debian/copyright
  * Bump debhelper build-dep and compat to 10
  * add debian/not-installed
  * Drop dh's parallel arg (no longer needed with dh >= 10)

 -- Clement Lefebvre <root@linuxmint.com>  Mon, 16 Apr 2018 15:39:24 +0100

xapp (1.0.4) sylvia; urgency=medium

  [ Clement Lefebvre ]
  * Packaging: Change description

  [ Michael Webster ]
  * Add xapp-gtk-utils.c/.h
  * Remove extra spaces inserted by clandestine foreign hackers.
  * Add XAppGtkWindow, with methods that shadow GtkWindow's icon setting ones.  This way, programs only need to change the window class, rather than adding extra code.
  * xapp-gtk-window: Add wrapper functions for GtkWindow subclasses.
  * xapp-gtk-window.*: Fix argument type for wrapper function.
  * xapp-gtk-window: Add progress features, refactor, add demo script for XAppGtkWindow.
  * xapp-gtk-window test script: Add an animate button (to test real-world effects on system reponsiveness while an operation is running.)
  * all: Fix build warnings, documentation.
  * xapp-gtk-window: Make xapp_gtk_window_new() handle the same arguments as gtk_window_new().
  * all: Allow XAppGtkWindows to be used in builder (ui) files and in Glade.
  * update some files modified by the build
  * pygobject/XApp.py: simplify and add an explanation as to why this file is here (to remind me in a year.)
  * xapp-gtk-window.c: Add xid-based functions
  * xapp-gtk-window: Move the xlib include into the .c file - it can cause namespace collisions (notably synaptic.)  It's ok to treat "Window" as an unsigned long, because that's what they are.

  [ Clement Lefebvre ]
  * xapp-gtk-window: Trap X errors when setting progress
  * Add a VAPI file to support Vala
  * Add a dependency on libxkbfile-dev for -dev pkg and build-dep.

 -- Clement Lefebvre <root@linuxmint.com>  Tue, 24 Oct 2017 12:06:19 +0100

xapp (1.0.3) sonya; urgency=medium

  [ Michael Webster ]
  * Fix build
  * xapp-kbd-layout-controller - update test script to reflect current api/intent

  [ Clement Lefebvre ]
  * Review licensing
  * Handle exceptions in usr/bin/upload-system-info

  [ JosephMcc ]
  * Add a couple of symbolic pane visibility icons
  * icons: Add an icon for regex-search

  [ leigh123linux ]
  * switch to the correct python deps

  [ Michael Webster ]
  * xapp-kbd-layout-controller.c: Allow up to 3 character labels.

  [ JosephMcc ]
  * Complete our set of pane icons
  * Add support for building gtk-doc

  [ leigh123linux ]
  * Migrate away from gnome-common deprecated vars and macros
  * Use python3 as all scripts are in python3

 -- Clement Lefebvre <root@linuxmint.com>  Wed, 03 May 2017 11:27:21 +0100

xapp (1.0.2) serena; urgency=medium

  [ Clement Lefebvre ]
  * Implement window blanking
  * Continued implementation of monitor blanking
  * Display: properly initialize values and add a function to know if monitors are blanked

  [ JosephMcc ]
  * xapp-display.c: Add a missing cast

  [ Clement Lefebvre ]
  * Added some symbolic icons needed by Xed

  [ JosephMcc ]
  * icons: Redesign the xapp-searchbar icons
  * formatting: Clean up code formatting

  [ Emmanuel ]
  * properly declare variable used in for loops

  [ JosephMcc ]
  * xapp-display: Add a missing cast
  * xapp-display: Don't use deprecated gtk_widget_modify_bg

  [ Michael Webster ]
  * debian: Fix multiarch location of typelib file, don't strip debug symbols.
  * Add XAppKbdLayoutController - this is a wrapper around libgnomekbd api to provide unique icons for each layout.
  * Update debian/control
  * Cleanup some leftover dependencies, some unneeded files, clean up gir scanning.

  [ Clement Lefebvre ]
  * Added /usr/bin/pastebin and /usr/bin/upload-system-info
  * Pastebin: Added support for fpaste
  * libxapp: Rename XAppDisplay -> XAppMonitorBlanker
  * Create README.md

  [ leigh123linux ]
  * Fix Warnings

  [ Michael Webster ]
  * Rework XAppKbdLayoutController:

 -- Clement Lefebvre <root@linuxmint.com>  Mon, 07 Nov 2016 15:56:44 +0000

xapp (1.0.1) sarah; urgency=medium

  * Initial version

 -- Clement Lefebvre <root@linuxmint.com>  Sun, 21 Aug 2016 11:59:50 +0100