Lintian Fixes - Statistics

Number of Fixes by Tag

Absorbed fixes are fixes that have either been pushed directly by the Janitor, or have been proposed as a merge request and then merged.

Lintian Tag Previously merged/pushed Ready but not yet merged/pushed
upstream-metadata-file-is-missing 5713 3949
uses-debhelper-compat-file 5957 3040
package-uses-old-debhelper-compat-version 5077 2743
upstream-metadata-missing-bug-tracking 3866 3493
upstream-metadata-missing-repository 3022 3277
out-of-date-standards-version 3138 2456
trailing-whitespace 2170 2059
insecure-copyright-format-uri 2061 883
package-uses-deprecated-debhelper-compat-version 1728 850
homepage-field-uses-insecure-uri 727 1007
vcs-obsolete-in-debian-infrastructure 981 620
vcs-field-not-canonical 972 550
older-debian-watch-file-standard 360 361
debian-changelog-has-wrong-day-of-week 292 350
tab-in-license-text 192 332
debian-watch-uses-insecure-uri 357 156
priority-extra-is-replaced-by-priority-optional 366 137
debian-rules-contains-unnecessary-get-orig-source-target 50 408
useless-autoreconf-build-depends 145 256
debian-changelog-line-too-long 215 106
debian-watch-file-is-missing 22 299
package-lacks-versioned-build-depends-on-debhelper 217 67
renamed-tag 103 167
team/pkg-perl/testsuite/no-testsuite-header 223 33
binary-control-field-duplicates-source 59 161
debian-rules-uses-unnecessary-dh-argument 56 138
package-needs-versioned-debhelper-build-depends 158 30
unversioned-copyright-format-uri 63 114
unused-override 62 111
debian-rules-sets-dpkg-architecture-variable 84 87
public-upstream-key-not-minimal 71 98
uses-deprecated-adttmp 40 87
copyright-refers-to-symlink-license 76 40
debian-control-has-unusual-field-spacing 56 54
vcs-field-uses-insecure-uri 17 90
old-source-override-location 41 53
out-of-date-copyright-format-uri 28 66
copyright-refers-to-versionless-license-file 54 33
debug-symbol-migration-possibly-complete 23 49
copyright-does-not-refer-to-common-license-file 19 48
out-of-date-copyright-format 27 36
older-source-format 23 38
debhelper-but-no-misc-depends 12 47
global-files-wildcard-not-first-paragraph-in-dep5-copyright 30 24
field-name-typo-in-dep5-copyright 15 37
unnecessary-testsuite-autopkgtest-field 39 11
custom-compression-in-debian-source-options 14 33
tab-in-licence-text 35 12
field-name-typo-dep5-copyright 34 12
possible-missing-colon-in-closes 33 6
vcs-field-mismatch 10 29
debian-control-has-empty-field 32 5
missing-debian-source-format 12 22
debian-changelog-file-contains-obsolete-user-emacs-setting 33 0
debhelper-tools-from-autotools-dev-are-deprecated 10 22
debian-control-has-obsolete-dbg-package 11 21
malformed-override 10 22
copyright-refers-to-versionless-license-file 22 7
patch-file-present-but-not-mentioned-in-series 22 5
ancient-standards-version 5 21
missing-build-dependency-for-dh-addon 14 12
maintainer-script-without-set-e 13 12
obsolete-field-in-dep5-copyright 17 8
ancient-python-version-field 14 10
unnecessary-team-upload 19 5
transitional-package-not-oldlibs-optional 5 18
xs-testsuite-field-in-debian-control 20 3
maintainer-script-empty 3 19
unused-license-paragraph-in-dep5-copyright 7 12
dh-clean-k-is-deprecated 8 9
debian-rules-missing-recommended-target 6 10
license-file-listed-in-debian-copyright 3 13
missing-vcs-browser-field 4 12
autotools-pkg-config-macro-not-cross-compilation-safe 13 2
font-package-not-multi-arch-foreign 2 13
missing-built-using-field-for-golang-package 12 3
no-dh-sequencer 13 2
xc-package-type-in-debian-control 5 10
desktop-entry-contains-encoding-key 2 12
copyright-not-using-common-license-for-apache2 5 8
space-in-std-shortname-in-dep5-copyright 8 5
systemd-service-file-refers-to-var-run 6 7
comma-separated-files-in-dep5-copyright 6 5
misspelled-closes-bug 8 3
no-homepage-field 4 7
build-depends-on-obsolete-package 5 5
missing-build-dependency-for-dh_-command 1 9
cute-field 1 7
debian-tests-control-autodep8-is-obsolete 2 6
libmodule-build-perl-needs-to-be-in-build-depends 3 5
missing-build-dependency-for-dh_command 7 1
upstream-metadata-yaml-invalid 1 6
dh-quilt-addon-but-quilt-source-format 2 4
homepage-in-binary-package 3 3
built-using-field-on-arch-all-package 3 1
debian-pyversions-is-obsolete 4 0
python-teams-merged 1 3
vcs-field-bitrotted 2 2
2 1
debian-watch-file-uses-deprecated-githubredir 2 1
executable-desktop-file 1 2
copyright-should-refer-to-common-license-file-for-apache-2 1 1
debian-pycompat-is-obsolete 2 0
newer-debconf-templates 1 1
obsolete-runtime-tests-restriction 1 1
public-upstream-keys-in-multiple-locations 1 1
skip-systemd-native-flag-missing-pre-depends 1 1
copyright-has-crs 1 0
debian-rules-calls-pwd 1 0
init.d-script-needs-depends-on-lsb-base 1 0
maintainer-also-in-uploaders 1 0
systemd-service-file-refers-to-obsolete-target 1 0
team/pkg-perl/vcs/no-team-url 1 0
uploaders-in-orphan 1 0
vcs-field-uses-not-recommended-uri-format 1 0
wrong-debian-qa-group-name 1 0
Total 39563 29549

Burndown