Codebase list orafce / d269128 debian / tests / installcheck
d269128

Tree @d269128 (Download .tar.gz)

installcheck @d269128raw · history · blame

#!/bin/sh

if [ -f /etc/locale.gen ]; then
	# Debian
	if ! grep -Fwq "en_US.UTF-8 UTF-8" /etc/locale.gen; then
		echo "en_US.UTF-8 UTF-8" >> /etc/locale.gen
		locale-gen
	fi
else
	# Ubuntu
	locale-gen en_US.UTF-8
fi

# to_multi_byte needs English, and UTF-8
export LC_ALL=en_US.utf8

set -e
for v in $(pg_buildext supported-versions); do
	rm -f orafunc.sql.in orafunc.sql
	make orafunc.sql PG_CONFIG=/usr/lib/postgresql/$v/bin/pg_config
	pg_buildext installcheck-$v
done