Codebase list oslo-sphinx / 98b9091d-e5fc-4aca-a690-c13a373a8c0f/main debian / rules
98b9091d-e5fc-4aca-a690-c13a373a8c0f/main

Tree @98b9091d-e5fc-4aca-a690-c13a373a8c0f/main (Download .tar.gz)

rules @98b9091d-e5fc-4aca-a690-c13a373a8c0f/mainraw · history · blame

#!/usr/bin/make -f

UPSTREAM_GIT = https://github.com/openstack/oslo.sphinx.git
include /usr/share/openstack-pkg-tools/pkgos.make

%:
	dh $@ --buildsystem=pybuild --with python3

override_dh_auto_clean:
	rm -rf build .stestr
	find . -iname '*.pyc' -delete
	for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done

override_dh_auto_build:
	echo "Do nothing..."

override_dh_auto_test:
	echo "Do nothing..."

override_dh_auto_install:
	pkgos-dh_auto_install --no-py2 --in-tmp