Codebase list oslo-sphinx / multiarch-fixes/main debian / rules
multiarch-fixes/main

Tree @multiarch-fixes/main (Download .tar.gz)

rules @multiarch-fixes/mainraw · history · blame

#!/usr/bin/make -f

UPSTREAM_GIT = https://github.com/openstack/oslo.sphinx.git
include /usr/share/openstack-pkg-tools/pkgos.make

%:
	dh $@ --buildsystem=python_distutils --with python3

override_dh_auto_clean:
	rm -rf build .stestr
	find . -iname '*.pyc' -delete
	for i in $$(find . -type d -iname __pycache__) ; do rm -rf $$i ; done

override_dh_auto_build:
	echo "Do nothing..."

override_dh_auto_test:
	echo "Do nothing..."

override_dh_auto_install:
	pkgos-dh_auto_install --no-py2 --in-tmp